Month: May 2007

Clust*r Fuck

Imported from the old lesombre.ca…

Wait, did I do that right?

Lately I’ve been bitchin’ and complainin’ a lot about one of our “partners” at work. I’m guessing that since we pay around 40k/year for support and 175k/year for licence I am fully justified to act like a little school girl whenever we don’t get the answers we need. Yes that’s US dollars. Not that it matters much these days.

Today our licence update issue on our cluster was resolved, after 31 days of quasi-silence on their part. Turns out the fix was really simple: one line of code to remove from a config file.

I admit that I was doubtful when I heard the solution. But then we tried it and it worked. Sorta. The licence updated, but the server would not restart. We had to put the line back in for the server to restart the server.

When I phoned the engineer to let him know that it worked, but that he had forgotten to tell me to put the line back in to make it work, his reply was:

“Oh. If you don’t mind, I’ll update our internal knowledge base with that information”

It took me a second or two (okay, more like 30) to process this information.

“WHAT? DO YOU MEAN THAT IT TOOK YOU 31 DAYS TO SOLVE A PROBLEM THAT THE SOLUTION – OR A GOOD PART OF IT – WAS ALREADY IN AN INTERNAL KNOWLEDGE BASE???”

“Well, you see when I got assigned to this case 2 weeks ago, I assumed that the simple solution had been tried without success…”

Needless to say, I am not impressed.  

I don’t think I’m allowed to tell you who they are, but their logo looks a little like this now… I anonymized it to protect the innocents.

(logo not imported)

Advertisements